Sections in this category

Creating & Managing Explorations

  • Updated

Sisu Explorations enable you to slice and dice your data manually. You can select the metric or dimension you want to explore, add or pivot by dimensions, and define filters—all without any SQL. You can then run the Exploration and visualize the output in table format or as various graphs that can be added to your dashboard and shared with other team members.

 

Related Articles:



Creating an Exploration

To create an Exploration:

  1. Select a Project, then click the “+” sign to the right of the Project / Metric / Analysis fields.
    The Create New Analysis modal will be displayed.
    Create_Exp_Modal.png

  2. Click on the Exploration option, enter a descriptive name in the Analysis name field, then select Create analysis.
    The “Create Exploration” screen will be displayed, with a control panel on the right side. Note that the “All fields” tab is selected by default.

  3. Select a Metric that you would like to explore from the “Available metrics” section.
    You can add multiple metrics to an Exploration as long as they share the same query or base table. The list of available metrics sharing the same data source are displayed on the right side.
    Exploration_Metric_Selected.png

    tip_icon.png Note that you can click the “+ Add” option to create a new Metric, if desired. Refer to Defining a Metric for more details.

  4. Optional:  Click Run.

    In the example above, we are exploring the Average Order Value as our Metric, and when we click Run, Sisu returns that value in the form of a bar graph (by default), and a table directly underneath.

    From here, you can further explore your data around this Metric by adding various dimensions as described below.

    tip_icon.png You can run your exploration at any time during the creation of your Exploration, to view results incrementally.

 

Adding Dimensions to your Exploration

Dimensions allow you to “slice” your data by one or more dimensions (or “rows”) listed in the “Dimensions” list in the control panel. There are two ways  to add dimensions to your Exploration:

  • Add one or more dimensions as “rows” to your data
  • Pivot dimension rows into columns in your data.

To add rows to your data:

  1. Click to the left of a dimension in the “Dimensions” list to check it, then click Run.
    Dimension_Selected.png
    In this example, we are exploring the Average Order Value, “sliced” by Order Channel as rows in the data table.

To pivot a dimension to a column:

  1. Click on the pivot icon to the right of a dimension in the “Dimensions” list.
    pivot_by_dimension.png
    The table section of the screen will update to show the pivoted data. Note that in our example, the Order Channels became columns instead of rows, as they were above.

    info_icon.png For date dimensions, you can click the “...” option to the right of the dimension and select “Truncate date” to specify how to aggregate your time column (e.g., by day, week, month, or year).

 

To check your dimensions:

  1. Select the “Table” tab in the control panel, and click Run.
    The results will be displayed.
    Exploration_with_Graph.png

 

About using multiple dimensions:

Note that you can specify more than one dimension. Continuing with our example, below we have added the List SKU dimension to our Exploration of Average Order Value by Order Channel.
Added_2nd_dimension.png

info_icon.png Remember, you can iterate and run your Exploration multiple times to achieve the result you want. To check the results, view the Exploration as a table or a graph of your choice. Refer to Interacting with Exploration Visuals for information on getting the most out of your visualizations.

 

Row and Column Limits

By default, the table is limited to 1000 rows. You can expand this to 5,000 rows by clicking on the table settings, editing the value, and clicking save.

Increase_row_limit.png

The number of columns is limited to 50 for pivoted data or 500 for unpivoted data.

 

Filtering Data in an Exploration

To filter data in an Exploration:

  1. Click on the filter icon to the right of any dimension, or the filter icon in the upper left corner of the screen.
    Filter_options.png

    info_icon.png Using the filter option on an individual dimension will automatically select that dimension to filter by, and it will be added as an “AND” condition.
    If you select the filter in the upper left corner of the screen, you can select any dimension as an AND or OR condition.

  2. Complete the filter fields as desired, click Save, and then Run.
    Filter_by_dimension.png

    info_icon.png

    Sisu indicates the number of filters you currently have applied with a number next to the filter icon in the upper left corner:

    number_of_filters.png



Editing the Visual

While the default graph type for Explorations is a bar chart, Sisu allows you to select different types of graphs so you can visualize your Exploration in many different ways.

To change your Explorations graph type:

  1. Select the “Graph” tab in the control panel, then select the type of graph desired.

    Graph_Types.png

  2. Make any adjustments desired to the graph settings in the control panel. Updates are applied in real-time.

    You can:
    1. customize labels for the y-axis and x-axis
    2. change axis positions (left-right)
    3. hide/display dimensions
    4. customize labels for dimensions
    5. change the color of each series (you can use your companies brand HEX colors as well as the provided default options)
info_icon.png

Refer to Interacting with Exploration Visuals for details on how to get the most out of your Exploration visualizations.

 

 

Editing the Table

To edit the Exploration’s Table:

  1. Select the “Graph” tab in the control panel, and hover over any element to display options available, including removing the element, adding a filter to the element, or pivoting the element between rows and columns.

    Editing_Graph.png

Managing Explorations

To rename, duplicate, or delete an Exploration:

  1. Click the <...> icon next to the Run button in the top right corner, and select the desired option.

    Managing_Exploration.png
info_icon.png

Using this menu, you can rename, duplicate, or delete the Exploration. The “Edit main query” option is described in the next section.

 

 

Editing the Main Query

To edit the main query:

  1. Click the <...> icon next to the Run button in the top right corner, and select “Edit main query.”
    Managing_Exploration.png

    A new tab will open in your browser, displaying the underlying main query for the Project your Exploration is associated with.

    info_icon.png

    For more information, refer to Editing a Metric's Underlying Query.